Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por JulioLopes 13 Jul 2019 às 15:04
Membro Novato
Mensagens: 4
Reputação: 0
#45547
Olá amigos.
Atualmente tenho uma dificuldade em meu novo estágio, pois estou realizando checklist em planilhas do excel e muitas das vezes tendo que realizar um cálculo ''manual'' para tal resultado.

Gostaria de saber a possibilidade de criação de uma função ou fórmula que automaticamente esse somatório final seja realizado sem a necessidade da intervenção manual.
Em anexo está um exemplo da planilha que utilizamos.
Apenas usuários registrados podem ver ou baixar anexos.
Por babdallas 13 Jul 2019 às 20:14
Membro 5 Estrelas
Mensagens: 2067
Reputação: 919
#45549
Veja se é isso.

Código: Selecionar todos=SOMARPRODUTO(ÍNDICE($E$4:E20;AGREGAR(15;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");CONT.SE($D$4:$D20;"<>"&"")*2+1)+1):ÍNDICE($E$4:E20;AGREGAR(14;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");1)-1))
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Deciog 14 Jul 2019 às 09:57
Membro 5 Estrelas
Mensagens: 1253
Reputação: 629
#45554
JulioLopes , Bom Dia.

Uma outra forma de fazer confere

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.
Por JulioLopes 19 Jul 2019 às 00:27
Membro Novato
Mensagens: 4
Reputação: 0
#45780
Deciog escreveu:JulioLopes , Bom Dia.

Uma outra forma de fazer confere

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio


Decio, boa noite.
A função é objetiva e quase atende o esperado, porém faltou pegar o valor do saldo inicial, que é uma variável importante para a consulta do saldo final pelos analistas.
Por JulioLopes 19 Jul 2019 às 00:29
Membro Novato
Mensagens: 4
Reputação: 0
#45781
babdallas escreveu:Veja se é isso.

Código: Selecionar todos=SOMARPRODUTO(ÍNDICE($E$4:E20;AGREGAR(15;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");CONT.SE($D$4:$D20;"<>"&"")*2+1)+1):ÍNDICE($E$4:E20;AGREGAR(14;6;(LIN($E$4:E20)-LIN($E$4)+1)/($E$4:E20="");1)-1))

babdallas, agradeço pela ajuda e dedicação.
Porém a planilha constantemente tem acréscimo de linhas, dependendo da movimentação financeira do dia.
E também ficou faltando pegar o valor do saldo inicial, que é importante para todo o cálculo.
Avatar do usuário
Por Deciog 19 Jul 2019 às 09:36
Membro 5 Estrelas
Mensagens: 1253
Reputação: 629
#45791
JulioLopes, Bom Dia.

Olha agora se atende suas necessidades, coloquei a soma do saldo

Se minha resposta foi útil, clique em obrigado é uma forma de agradecimento da ajuda

Decio
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 19 Jul 2019 às 09:58
Excel Expert
Mensagens: 3892
Reputação: 1683
#45793
Julio,

Veja se o que fiz lhe ajuda, eu converti os dados em tabela, assim ao acrescentar novos dados, o cálculo é atualizado automaticamente.

Abs
Apenas usuários registrados podem ver ou baixar anexos.