Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por EvandroReis 14 Jun 2019 às 18:41
Membro Novato
Mensagens: 7
Reputação: 0
#44752
Olá boa tarde pessoal!! ;)
Tenho uma planilha com valores que devem ser somados somente na data atual e em uma unica célula.
Ex: DATA VALOR
(B20) 11/06/2019_____________R$300 Neste dia apos todas as somas só aparecera este valor. O dia anterior é ignorado.
(B21) 12/06/2019_____________R$150 Neste dia apos todas as somas só aparecera este valor. O dia anterior é ignorado.
(B22) 13/06/2019_____________R$220 Neste dia apos todas as somas só aparecera este valor. O dia anterior é ignorado.
:
:
(B500) Dia Atual inserido manualmente. Valor inicial = R$ 0,00
Tenho como referencial uma célula com a função: HOJE()
E a soma a ser feita é: SOMA(M20:M500;-SOMA(J20:J500)
Esta soma será apresentada em célula unica não há possibilidade de estender para outras células. E se possível sem a criação de células adicionais pois tenho problemas com espaço. Sem desmembrar a soma.
Talvez seja erro de sintaxe mas, já tentei SE, SOMASE, SOMASES......
A duvida é como comparar um intervalo de datas (B20:B500) com uma data (HOJE()) e efetuar a rotina SOMA(M20:M500;-SOMA(J20:J500).
SE($B20:B500;=HOJE();SOMA(M20:M500;-SOMA(J20:J500);0)
SOMASE(B20:B500;"="&HOJE();SOMA(M20:M500;-SOMA(J20:J500)
Entre outras tentativas nada deu certo. Se alguém puder por gentileza me dar uma ajuda eu agradeceria muito.
Desde já deixo aqui o meu muito obrigado. Um abraço.
Avatar do usuário
Por FelipeMGarcia 14 Jun 2019 às 19:02
Excel Expert
Mensagens: 3856
Reputação: 1663
#44754
Amigo, anexa um modelo da sua planilha com o resultado desejado que fica mais fácil de ajudar, para anexar, vá em + resposta, adicionar anexo.

abs
Avatar do usuário
Por gfranco 14 Jun 2019 às 23:19
Membro 5 Estrelas
Mensagens: 1994
Reputação: 1062
#44760
Amigo,
veja se é isso que precisa:
Apenas usuários registrados podem ver ou baixar anexos.
Por EvandroReis 15 Jun 2019 às 13:54
Membro Novato
Mensagens: 7
Reputação: 0
#44772
Muito obrigado mesmo, gfranco pela atenção mas por descuido meu, deixei de mencionar um detalhe.
A sua formula SOMARPRODUTO((A3:A12=HOJE())*(F3:F12)) que você me indicou ,serviu perfeitamente para tornar o valor da da atual igual azero. Contudo eu também já havia encontrado na semana passada a formula SOMASE(A3:A12;"="&I9;F3:F12), Sendo I9=HOJE() que também resolveu o problema do somatório e data.
Fazendo simulações com a planilha percebi que a formula que mais se encaixa a minha necessidade é =SOMA(E3:E12;-SOMA(C3:C12)) e ai está o problema, não consigo atrelar esta formula especifica a HOJE(). Eu atualizei a planilha com mais detalhes e mais explicações descritas na própria planilha, deixo em anexo. Desde já agradeço a atenção.
Apenas usuários registrados podem ver ou baixar anexos.
Por EvandroReis 16 Jun 2019 às 01:11
Membro Novato
Mensagens: 7
Reputação: 0
#44787
:idea: Consegui utilizando dois SOMASE.
SOMASE(B20:B500;"="&HOJE();M20:M500)-SOMASE(B20:B500;"="&HOJE();J20:J500).
Deixo aqui os meus sinceros agradecimentos ao FelipeMGarcia e ao gfranco, pela atenção. Um abraco a todos. :D