Tudo que estiver relacionado ao Excel básico, como somar, calcular média, colocar bordas, etc.
Por Alcaraz 04 Jun 2020 às 18:43
Membro Novato
Mensagens: 3
Reputação: 0
#55613
Olá,

Sei que existem as fórmulas modo.única e modo.mult para conseguir capturar a moda em uma lista de dados. Porém preciso capturar a moda em um banco de dados partindo de certos parâmetros / critério.
No caso tenho um banco de dados separados em diversas varáveis, cada uma em uma coluna, preciso capturar a moda da quantidade de profissionais, porém segmento por lote e serviço. Estas três varáveis estão em colunas diferentes no banco. Já tentei aninhar a função =Se com a função modo.único, tarabé tentei aninhar a função =E com a função modo.única, enfim não obtive sucesso em nenhuma tentativa.

EXemplo:
Imagem


Preciso da moda nos quantitativos da coluna C, separados por lote e serviço

Será que alguém tem alguma solução por favor?
Por Kledison 04 Jun 2020 às 20:26
Excel Expert
Mensagens: 899
Reputação: 408
#55614
Boa noite!

tente com a fórmula matricial abaixo,lembrando que deverá apertar CONTROL+SHIFT+ENTER para sair da fórmula

Código: Selecionar todos=SEERRO(MODO.ÚNICO(SE((A2:A7=G1)*(B2:B7=G2);C2:C7));"")


Como não anexou arquivo, altere as referências das células na fórmula.

Verifique se é desse jeito.

Att
Apenas usuários registrados podem ver ou baixar anexos.
Por Alcaraz 05 Jun 2020 às 09:45
Membro Novato
Mensagens: 3
Reputação: 0
#55626
Olá, muito obrigado.
Porém não consegui aplicar a fórmula trocando as células. Se puder dar uma olhada, por favor, segue o arquivo em em anexo
Apenas usuários registrados podem ver ou baixar anexos.
Por Kledison 05 Jun 2020 às 20:03
Excel Expert
Mensagens: 899
Reputação: 408
#55648
Boa noite!

Verifica o anexo se está do jeito esperado, coloquei alguns valores na Aba BASE, coluna D par ao Lote 01.

Att
Apenas usuários registrados podem ver ou baixar anexos.