Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#67014
Bom dia,

pretendo fazer o produto de um intervalo de células. Duas dessas células são para somar e multiplicar pelas células restantes. O problema é que quando as células a somar estão vazias o resultado do produto é também zero.
A fórmula que usei para o Total:
=PRODUTO(SOMA(A4:B4);C4;D4)

Existe alguma forma de contornar essa situação?
Imagem em anexo

Obrigado
Imagem
#67016
pmfc26 escreveu: 18 Set 2021 às 07:40 Existe alguma forma de contornar essa situação?
Você não informou qual o resultado desejado nesse caso.
Seguem 2 opções, a primeira retorna vazio e a segunda, que é uma pequena modificação na fórmula sugerida pelo Mestre @Estevaoba , desconsidera a SOMA().

=SE(E(A4="";B4="");"";PRODUTO(SOMA(A4:B4);C4;D4))

=SE(E(A4="";B4="");PRODUTO(C4;D4);PRODUTO(SOMA(A4:B4);C4;D4))
pmfc26 agradeceu por isso
Botões

Olá, @NunoGuimaraes . Tomei como base […]

Olá, @fernandogaseo . Segue uma solu&c[…]

Muito obrigado! De fato somente ajustar a declara[…]

Você tem linhas nas tabelas que estão[…]

MIN[dCalendario[Data]) vai retornar o data m&iacut[…]

Boa Tarde! A Macro existente na planilha em anexo,[…]

Tente assim: Dim xRg As Range Private Sub ComboB[…]

Olá pessoal! Tenho uma planilha no trabalh[…]