Assuntos relacionados a criação de medidas, fórmulas e funções DAX, relacionamentos etc
Por LumaJardim
#62486
OLÁ!!


Estou com um erro numa medida criada em que a seguinte msg aparece:

MdxScript (Model) (149,9) Erro de Cálculo na Medida 'Aux - Positivo Realizado[Positivo Realizado]: Não é possível converter o valor '103-60' do tipo Text no tipo Integer.

O problema é que os dados dessa coluna está formatado como decimal e não no tipo texto, além disso, esse valor não existe nessa base.

Essa é a fórmula da medida e o da medida é 00:00:00:


Positivo Realizado =
VAR vHorasDecimal = [Pos R Decimal]
VAR vHoras = INT(vHorasDecimal)
VAR vMinutosDecimal = 60 * (vHorasDecimal - vHoras)
VAR vMinutos = INt(vMinutosDecimal)
VAR vSegundos= ROund (60 * (vMinutosDecimal - vMinutos),0)
VAR vHH = if(len(vHoras)=1,"0" & vHoras, vHoras)
VAR vMM = if(len(vMinutos)=1,"0" & vMinutos, vMinutos)
var vSS = if(len(vSegundos)=1,"0"& vSegundos,vSegundos)
return
CONVERT(vHH&vMM&vSS,INTEGER)


Já tentei mudar a ultima linha para outro tipo, que não seja Integer, e mesmo assim não deu certo!

O que posso fazer pra resolver?
EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]

Boa tarde!! Tenho uma planilha para calculo de ho[…]