Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Jeczei
#59788
Pessoal, boa tarde
Peço ajuda na solução para encontrar em uma tabela, o valor da cota de um determinado fundo (1o parâmetro) a partir da data informada (2o parâmetro)
Segue planilha anexa para facilitar o entendimento.
Obrigado antecipadamente
Abraços,
Você não está autorizado a ver ou baixar esse anexo.
#59789
Boa Tarde

Uma solução seria você ajustar seu banco de dados (no caso as movimentações) de forma vertical, assim quando forem surgindo novas movimentações devem sempre ficar uma abaixo da outra repetindo as informações de Fundo, Natureza e Data. O saldo aconselho a fazer um resumo separado.

Para utilizar dois parâmetros no PROCV você pode concatenar as informações no seu banco de dados exemplo =Ativo&Data_Movimentação (colocando as respectivas células). Criando uma coluna com o nome de ID, como no exemplo. No local que você irá visualizar a informação faça a mesma concatenação para ver a informação. No seu exemplo 1 o PROCV ficaria com o início assim =PROCV($B$12&$B$13; (concatenando a B12 e a B13).

Para questão dos valores, vi que dependendo do tipo de movimentação você quer acrescentar ou diminuir do saldo, na nova estrutura de dados você pode trabalhar com valores negativos e positivos, assim para o resumo um simples SOMASE irá trazer o saldo correto.

Veja no anexo a forma que estruturei os dados e PROCV. Desta forma ficará mais fácil pra você utilizar a planilha.
Você não está autorizado a ver ou baixar esse anexo.
Jeczei agradeceu por isso
#59791
Cleivin, estou avaliando a sua recomendação, pois a planilha original tem mais algumas colunas que não coloquei aqui para facilitar.
Amanhã lhe retornarei com a avaliação, mas desde já agradeço a sua atenção e retorno.
Abs

Segue uma ideia, veja se aproveita. 1. elabore um[…]

Pessoal, ao salvar minha tabela dinâmica no […]

DÚVIDA: Como gerar a data final?

Isso mesmo Strogonoff, muito obrigado! Sobre a su[…]

Variáveis em um Dashboard

Você precisa de um gráfico dinâ[…]

Bom dia! Estou precisando de uma ajuda com SQL e V[…]

Como você não informou o horár[…]

Como abrir tela de Logon do SAP ECC?

@FAMenezes , Tudo bom... sei que já faz um[…]

Rotina e Macro

Oi. Tenho uma planilha com um jogo. Nele os partic[…]