Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#59790
Prezados, bom dia!

A planilha contém os produtos de duas filiais cujas vendas mensais superaram a meta.

Eu preciso que os códigos de produtos da filial A estejam lado a lado com os correspondentes da filial B.

As linhas que não há correspondentes devem ficar vazias.

Ex. Mês 02/2020 Cód prod. Filial A Cód produto Filia B
380734 380734
101897 101897
261101 vazio
564678 vazio
432789 432789
etc...
Bom, são muitos produtos e várias filiais, mas segue uma planilha com alguns produtos de duas filiais


Obrigado,
Você não está autorizado a ver ou baixar esse anexo.
#59838
Para listar os códigos da filial A, use esta fórmula matricial em G2 (Cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter) e copie para baixo até resultar em branco:
Código: Selecionar todos
=SE(É.NÃO.DISP(ÍNDICE($B$3:$B$100;CORRESP(1;(CONT.SE(G$1:G1;$B$3:$B$100)=0)*($B$3:$B$100<>"")*($A$3:$A$100="02/2020");0)));"";ÍNDICE($B$3:$B$100;CORRESP(1;(CONT.SE(G$1:G1;$B$3:$B$100)=0)*($B$3:$B$100<>"")*($A$3:$A$100="02/2020");0)))
Para os códigos correspondentes da filial A, cole esta outra (matricial também) em H2 e copie para baixo:
Código: Selecionar todos
=SE(É.NÃO.DISP(CORRESP(G2;SE($D$3:$D$100="02/2020";$E$3:$E$100);0));"";G2)
O argumento "02/2020" pode ser substituído por uma célula que contenha essa informação.
Se usar outra coluna que não seja a coluna G, altere a parte G$1:G1 para a nova coluna usada. E se começar em uma linha que não seja a linha 2, altere o número da linha para um a menos da nova linha usada.
Favor conferir no anexo.

Good luck!
Você não está autorizado a ver ou baixar esse anexo.

Segue uma ideia, veja se aproveita. 1. elabore um[…]

Pessoal, ao salvar minha tabela dinâmica no […]

DÚVIDA: Como gerar a data final?

Isso mesmo Strogonoff, muito obrigado! Sobre a su[…]

Variáveis em um Dashboard

Você precisa de um gráfico dinâ[…]

Bom dia! Estou precisando de uma ajuda com SQL e V[…]

Como você não informou o horár[…]

Como abrir tela de Logon do SAP ECC?

@FAMenezes , Tudo bom... sei que já faz um[…]

Rotina e Macro

Oi. Tenho uma planilha com um jogo. Nele os partic[…]