Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por rahfaeu 13 Set 2017 às 18:39
Membro 1 Estrela
Mensagens: 26
Reputação: 4
#26430
Olá Galera, bom dia!

Preciso de uma ajuda expert: Calcular a quantidade de produto que devo enviar para um cliente para mantê-lo abastecido por x dias (~28 dias), a fim de manter o estoque do cliente abastecido até o final do mês, considerando o consumo diário de cada produto (quanto ele vende por dia), e tenho a restrição de enviar quantidade em múltiplos de cada produtos (cada produto tem um múltiplo estabelecido), considerando um limite de envio, para não enviar muitos produtos a mais, considerar manter estoque de no mínimo 27 dias, e no máximo 33 dias (Limites).

Estou enviando um exemplo com os seguintes dados

Fator = Valor fixo determinado (múltiplo de cada produto)
Exemplo 1: Produto A possui o múltiplo de 30 unidades, ou seja, tenho que enviar quantidade dentro do múltiplo estabelecido: 30 unidades / 60 unidades / 90 unidades / 120 unidades...
Exemplo 2: Produto B possui o múltiplo de 12 unidades, ou seja, tenho que enviar quantidade dentro do múltiplo estabelecido: 12 unidades / 24 unidades / 36 unidades / 48 unidades...

Estoque Total (Unidades) = Quantidade de Produtos Atual no estoque do Cliente

Venda Diária (Unidades) = Quantidade Vendida por Dia

Ressuprimento (Unidades) = Quanto em Unidades enviar respeitando o múltiplo de cada produto

Dias de Estoque Suprido (dias) = Total de dias que o cliente terá estoque para venda (limite entre 27 e 33 dias)

Espero que dê para entender a necessidade e conto a com a ajuda.

Abraços!
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por FelipeMGarcia 13 Set 2017 às 19:08
Excel Expert
Mensagens: 2448
Reputação: 929
#26431
Amigo, não entendi o que quer calcular e em qual coluna quer fazer o cálculo, você poderia colocar um exemplo de resultado para que possa te ajudar?

Abs
Por Estevaoba 13 Set 2017 às 22:32
Membro 2 Estrelas
Mensagens: 110
Reputação: 43
#26438
Boa noite.

Tente esta fórmula.

=SE(QUOCIENTE((33-INT(C3/D3))*D3;B3)*B3<0;0;QUOCIENTE((29-INT(C3/D3))*D3;B3)*B3)

Não é a solução ideal, mas já é um começo.

Ab.
Por babdallas 14 Set 2017 às 01:05
Membro 5 Estrelas
Mensagens: 478
Reputação: 217
#26440
Veja se ajuda.
Apenas usuários registrados podem ver ou baixar anexos.