Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Sergio 26 Jun 2015 às 12:34
Membro Novato
Mensagens: 2
Reputação: 0
#1496
Olá a todos, tenho a seguinte situação: Tenho uma lista em uma coluna com todos os feriados "Já incluso os finais de semana" e tenho vencimentos de documentos "boleta,cheques" e preciso que na situação do vencimento ocorrer em um dia não útil "Q conste na lista" seja acrescido um dia a mais até chegar no próximo dia útil. Grato!
Avatar do usuário
Por JeanHard 26 Jun 2015 às 14:14
Membro 1 Estrela
Mensagens: 103
Reputação: 27
#1502
Tem como anexar seu exemplo. Se tiver post no formato Zip pois onde estou só abre esse formato.
Abraços.
Por MarcilioLobao 26 Jun 2015 às 17:43
Membro 1 Estrela
Mensagens: 85
Reputação: 50
#1515
Sérgio, Boa Tarde.

A Função DIATRABALHO lhe permite fazer exatamente isso que você precisa.

Sintaxe:
=DIATRABALHO( "a data que caiu o feriado ou fim de semana" ; "Qte de dias úteis após")

No seu caso use 1 como "Qte de dias úteis após"
Faça um teste e diga-nos se funcionou para você.

Eu espero ter ajudado.
Por alefeufei 01 Jul 2015 às 19:19
Membro Novato
Mensagens: 1
Reputação: 0
#1570
Márcio sou novo fórum e não sei se deveria abrir um novo tópico para o mesmo assunto.

Estou com um caso semelhante e não sei como resolver. Exemplo.

tenho no A1 uma data 30/06/2015 e se eu quero que o B1 me retorne uma data de 31 dias, eu somo em B1 = A1+31 e me retorna a data com 31 dias após. O meu problema é que se a data cair, sexta, sábado e domingo, eu quero que retorne o valor segunda feira, ou seja 3/8/2015 ao invés de 31/07

Há como resolver?



MarcilioLobao escreveu:Sérgio, Boa Tarde.

A Função DIATRABALHO lhe permite fazer exatamente isso que você precisa.

Sintaxe:
=DIATRABALHO( "a data que caiu o feriado ou fim de semana" ; "Qte de dias úteis após")

No seu caso use 1 como "Qte de dias úteis após"
Faça um teste e diga-nos se funcionou para você.

Eu espero ter ajudado.
Por duds 01 Jul 2015 às 19:51
Membro 3 Estrelas
Mensagens: 220
Reputação: 71
#1571
Boa tarde alefeufei,

Se a sua dúvida inicial foi sanada, você deveria ter marcado o tópico como resolvido, mas como não marcou, não tem problema neste caso, de utilizar este tópico, pois o tópico é seu e a sua nova dúvida se enquadra no mesmo assunto da dúvida anterior, mas mais uma vez, assim que sua dúvida é sanada, marque o tópico como resolvido e se outra surgir, crie outro tópico!

Respondendo a sua dúvida, utilize a seguinte fórmula:
=SE(DIA.DA.SEMANA(A1+31)=6;A1+34;SE(DIA.DA.SEMANA(A1+31)=7;A1+33;SE(DIA.DA.SEMANA(A1+31)=1;A1+32;A1+31)))

Qualquer dúvida estou à disposição.

Att.
Por Sergio 22 Jul 2015 às 12:42
Membro Novato
Mensagens: 2
Reputação: 0
#1785
Bom dia, infelizmente não obtive e retorno esperado, pode ser q fiz algo errado, mas é o seguinte: tenho uma data inicial de 07/10/2015 e desejo um vencimento um dia útil após esta data, tenho uma tabela de feriados "fictícia" de 07/10/2015, 08/10/2015 e 09/10/2015, deveria retornar a data 11/10/2015! porém está retornado dia 12/10/2015, é isto mesmo ou fiz algo errado, segue a formúla: =DIATRABALHO(A3;1;K6:K8) (A3 data inicial) ( 1 dia útil ) (k6:k8 lista dos feriados)


Grato, pela atenção