Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por RCA
#66507
Preciso calcular a média de tempo estudo por dia da semana, entretanto, alguns valores de data são repetidos (valores esses que geram o dia da semana respectivo) e preciso contar esses dias apenas como 1 dia.

Cheguei a formula: =SOMASE(tab_BD[dia da semana];S12;tab_BD[Tempo Estudo])/CONT.NÚM(1/FREQÜÊNCIA(SE(tab_BD[DIA]<>"";SE(tab_BD[dia da semana]=S12;CORRESP(tab_BD[DIA];tab_BD[DIA];0)));LIN(tab_BD[DIA])-1))

Imagem

Nesta situação eu esperava que as datas 24/08 contassem apenas como uma data.

Imagem
Imagem

Quando faço a avaliação da formula, percebo que a função Frequência esta agrupando os valores e o resultado final é "1", em veze de ser "5"
Por osvaldomp
#66617
Sugestão: deixe de lado a sua tentativa de fórmula, disponibilize uma amostra do seu arquivo Excel com alguns dados (imagens não servem) , coloque manualmente o resultado desejado com as necessárias explicações na própria planilha.
Por osvaldomp
#67018
RCA escreveu: 24 Ago 2021 às 17:30 ... alguns valores de data são repetidos ... e preciso contar esses dias apenas como 1 dia.
Veja se ajuda.
Para essa primeira parte aí acima, a fórmula matricial abaixo irá contar as datas em B12:B19, sendo que as datas repetidas serão contadas uma só vez. A fórmula retorna 3.
Código: Selecionar todos
=SOMA(1/CONT.SE(tab_BD[DIA];tab_BD[DIA]))
RCA agradeceu por isso
Por RCA
#67019
Boa noite Osvaldo, primeiramente obrigado pela sua ajuda.

De fato resulta em 3 a formula, porem, ela faz a contagem de datas distintas apenas. O que eu necessito é a inclusão de um segundo critério, que são os dias de semana.

Por exemplo, as datas 17/9/2021 e 24/9/2021, ambas aparecem repetidas por 2x. O que eu preciso é que a formula conte como 2 domingos, ignorando as datas repetidas.

Veja que a função frenquência esta acumulando as datas - {2,0,0,...} -
O que deveria ficar assim - {1,1,0,0...} -
Por osvaldomp
#67022
Olá, @RCA .

Em B12:B19 há as datas abaixo à esquerda. Acrescentei os correspondentes dias da semana à direita.

16/9/17 - sábado
16/9/17 - sábado
16/9/17 - sábado
16/9/17 - sábado
17/9/17 - domingo
17/9/17 - domingo
24/9/17 - domingo
24/9/17 - domingo


A fórmula que passei conta as datas duplicadas uma única vez. Dito de outra forma, ela conta datas diferentes.
Então a fórmula retorna 3, ou seja, 16/9/17, 17/9/17 e 24/9/17.

Porém você quer contar as datas levando em conta os dias da semana. Qual o critério e qual o resultado esperado?
________________________________________________________________________________________________________

Critério1 - você quer contar dias da semana duplicados uma única vez, dito de outra forma, contar dias da semana diferentes?
Nesse caso o resultado seria 2: sábado e domingo.
________________________________________________________________________________________________________

Critério2 - você quer contar associando datas & dias da semana?
Nesse caso o resultado seria 3:
16/9/17 - sábado ~~~> seria contado uma vez,
17/9/17 - domingo ~~~> seria contado uma vez e
24/9/17 - domingo ~~~> seria contado uma vez.
_________________________________________________________________________________________________________

Ou nenhum dos anteriores? Critério3 ... ?
Por RCA
#67024
Boa tarde Osvaldo.

Exatamente como esta no Critério 2 que você explicou.

O que pretendo fazer é tirar a média dos dias estudados de acordo com o dia da semana.
Por exemplo:

16/9/17 - sábado ~~~> seria contado uma vez,
17/9/17 - domingo ~~~> seria contado uma vez e
24/9/17 - domingo ~~~> seria contado uma vez.

Somaria os valores de todos os domingos com o SOMASE e dividiria pelos domingos contados. Que no caso em tela seriam apenas 2.
Por osvaldomp
#67030
RCA escreveu: 19 Set 2021 às 12:55
Exatamente como esta no Critério 2 que você explicou.
Esse comentário seu aí abaixo não bate com o Critério2. Continua confuso. :?

Somaria os valores de todos os domingos com o SOMASE e dividiria pelos domingos contados. Que no caso em tela seriam apenas 2.
Eu estou tentando lhe ajudar a fazer a contagem das datas/dias da semana de interesse, para depois você incluir na sua fórmula que calcula a média, então não misture por enquanto, vamos tratar SOMENTE da contagem, que eu ainda não entendi o que você quer exatamente.

Você está interessado em contar somente os domingos, conforme você comentou acima ?

Seria mais proveitoso se você preparar uma planilha com TODAS as variações possíveis de datas e dias da semana, coloque manualmente a contagem desejada com as explicações de como chegou ao resultado. Não inclua nada que se relacione ao cálculo da média, deixe para depois. Prepare os dados como Intervalo e não como Tabela Excel. Não inclua na planilha NADA que não se relacione com a contagem de datas/dias da semana, depois você adapta na sua planilha original.

Arquivo Teste

Boa Tarde Sou novo no BI. Gostaria de saber como […]

Filtro suspenso bugado

Anexa o arquivo, oferecer uma soluçã[…]

Ajuda para Vincular colunas.

Na sua Planilha2 vc tem uma fórmula em q pa[…]

Faaala @DJunqueira . Camarada, vc salvou uma v[…]

@DJunqueira , Muuuito obrigada! :)

Conexão odbc

Bom dia pessoal, estou com problemas em fazer co[…]

Adidas Yung-1 Pas Cher

Adidas Yung-1 Pas Cher https://www.solewishes.co[…]