Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
Por Leonardo1234
#64947
Olá,

Eu quero saber como abreviar milhões em "M" dentro da formula texto.

Eu consegui fazer isso na formatação personalizada através do formato R$ 0,0.. "M" aplicado na célula E2, porém o mesmo formato não está dando certo dentro da formula TEXTO na célula B2.

Segue anexo.

Agradeço a ajuda.
Você não está autorizado a ver ou baixar esse anexo.
Por MarcilioLobao
#64948
Leonardo1234, Boa noite.

Lembre-se que quando você muda a formatação da célula, o valor continua um número podendo ser utilizado em cálculos.

Ao utilizar a função TEXTO, o resultado não pode ser utilizado em nenhum cálculo.

Tente utilizar: =TEXTO(A2;"R$ 0,0..") & " M"

Era isso o que você queria?
Espero ter ajudado.

texto-alterado.xlsx
Você não está autorizado a ver ou baixar esse anexo.
Por Leonardo1234
#64949
Olá MarcilioLobao, sim, minha intenção é virar um texto mesmo.

Deu certo de fato sua formula, porém eu imaginei que seria possivel colocar o "M" dentro dentro da própria formula sem precisar concatenar por fora.

Com a abreviação de mil em k que eu fiz embaixo por exemplo da certo, da uma olhada.

Mas agradeço de qualquer forma.
Você não está autorizado a ver ou baixar esse anexo.
Por MarcilioLobao
#64959
Leonardo1234, Bom dia.

"...porém eu imaginei que seria possivel colocar o "M" dentro dentro da própria formula sem precisar concatenar por fora..."
Nesse caso experimente usar: =TEXTO(A2;"R$ 0,0.. \M")

"...Com a abreviação de mil em k que eu fiz embaixo por exemplo da certo, da uma olhada..."
O porquê com a letra K funciona e com a letra M não funciona, eu não sei explicar.

Era isso o que você queria?

Eu espero ter ajudado.

Tenho uma planilha de extrato bancário (ane[…]

CODIGO VBA

Osvaldo muito obrigado, era isso mesmo valeu.

Linhas em colunas

Tenho uma planilha de extrato bancário (ane[…]

AJUDA PLANILHA DE CALCULO DIARIO

Boa noite pessoal. Tenho uma planilha que faz uns […]

Licença para desenvolvedor autônomo

Gostaria de saber qual o melhor caminho, ou quais […]

:D :D :D :D :D MUITO OBRIGADO MESTRE VILMAR!![…]

proporcionalidade

Olá, estou precisando de um calculo proporc[…]

Fiquei com algumas duvida Poste o modelo e digita[…]