Tudo que estiver relacionado ao Excel básico, como somar, calcular média, colocar bordas, etc.
#61801
Olá, logo de cara já adianto que não sou um ''entendedor'' de Excel, por isso venho pedir ajuda a vocês para concretizar minha ideia:
Preciso criar uma lista suspensa que listará várias fórmulas matemáticas para cálculo de % de gordura. Cada fórmula utiliza dados diferentes, no caso, células diferentes para coletar as informações e fazer o cálculo. Além de que preciso mostrar o resultado em outra célula.

Por exemplo: Vão haver 7 células para preenchimento, sendo elas: Ab, Tr, Si, Am, Se, To, Co
Fórmula 1 = utiliza apenas a Ab, Tr, Si
Fórmula 2 = utiliza apenas Am, Se, Co
Fórmula 3 = utiliza apenas Tr, To, Co
E por aí vai outras fórmulas...

Talvez com a ajuda de vocês eu consiga fazer isso funcionar
#61804
YagoViccari, Boa tarde.

Fica um pouco superficial demais sem você realmente nos fornecer mais detalhes ou como você gostaria que a planilha se parecesse.

Essa lista de fórmulas na LISTA SUSPENSA, você está pensando em mostrar a fórmula como referência ou você quer que a fórmula nessa lista realmente funcione aí a cada nova escolha?

As fórmulas podem aparecer em formato texto e em outra célula você apresenta o resultado fruto de uma pesquisa em uma tabela.

Mas como disse, antes que fiquemos falando de filosofia dê-nos detalhes mais realistas da sua necessidade.

Afinal é você que sabe o que essas variáveis significam:Ab, Tr, Si, Am, Se, To, Co

Estou disposto a ajudar.

Aguardo resposta.
#61805
Não me parece viável com recursos nativos de planilha, poder escolher fórmulas em uma lista suspensa e executá-las.

Segue outra ideia.
Considerando uma lista suspensa em A1 formada por números (1, 2, 3, ...), ou por textos, na célula que você quer o resultado dos cálculos coloque alguma fórmula como esta abaixo.
=SE(A1=1;cálculo1;SE(A1=2;cálculo2;SE(A1=3;cálculo3;...

A partir daí duas opções para colocar no lugar de cálculoX na fórmula acima:
1) colocar o cálculo desejado diretamente na fórmula, algo assim, no lugar de "cálculo1" coloque ~~~> 3*Si + 18/To ...
2) colocar uma fórmula em outra célula para efetuar o cálculo, por ex. em B1, ~~~> =3*Si + 18/To ... e aí no lugar de "cálculo1" coloque B1.

Idem para os demais cálculos.
#61806
Um pequeno exemplo:
27-01-2021_Guru_Percentual-de-gordura.xlsx
Você não está autorizado a ver ou baixar esse anexo.
Kledison agradeceu por isso

Fórmulas matriciais. Cole e confirme com Ct[…]

=EXT.TEXTO(SUBSTITUIR($F5;"/";REPT(&quo[…]

MACRO COM PLANILHA BLOQUEADA

@Inovacao , além da tecla de atalho me[…]

Imagens de url dinâmino

Boa noite a todos tenho num ficheiro um link din&a[…]

Tabular documento complexo

Boa noite, Gostaria de uma macro que tabulasse um[…]

Boa tarde Segue uma opção. Até[…]

Erro na Medida

Tem como enviar seu pbix?

Se for para contar apenas os admitidos, independen[…]