Tudo que estiver relacionado ao Excel básico, como somar, calcular média, colocar bordas, etc.
Por ccbairros 03 Dez 2019 às 23:49
Membro Novato
Mensagens: 17
Reputação: 1
#50856
Mais uma vez venho aqui pessoal
Tenho uma planilha com diversos dados

Joana - Brasileira - Mulher - Baiana - RG25525
Maria - Americana - Mulher - Catarinense - RG 23435

e assim por diante.
Mas eu preciso ordenar de acordo com uma coluna em outra planilha que contem o RG delas e de outros.
RG 24328
RG28945
RG25525
RG65989
RG23435

Estou tentando uma macro pra poder agilizar o processo...mas com meus conhecimentos quase nulo svou demorar um pouco até deixar funcional, talvez uma formula para "copiar" alinha inteira de acordo com acoluna seja mais simples no primeiro momento.
Avatar do usuário
Por Estevaoba 06 Dez 2019 às 08:53
Membro 5 Estrelas
Mensagens: 728
Reputação: 349
#50948
Para facilitar a criação e teste de fórmulas, favor postar uma planilha exemplo com algumas linhas da sua planilha real, e coloque manualmente o resultado esperado, explicando por que ele deve ser assim.
Clique em +Resposta, Adicionar um anexo.

Ab.
Por ccbairros 16 Dez 2019 às 08:03
Membro Novato
Mensagens: 17
Reputação: 1
#51167
Fiz uma planilhja de exemplo pra facilitar...
A real tem muito mais colunas,mas já dá pra ter uma ideia
A planilha1 tem os dados crus
A planilha2 tem a coluna de base para ordenar
e a planilha RESULTADO como deve sair.
O script procura na coluna CARTON NO da Planilha1, os números correspondentes na mesma coluna da Planilha 2 e joga na planilha RESULTADOS, na ordem da Planilha2 todos os dados da linha da Planilha1.
Apenas usuários registrados podem ver ou baixar anexos.
Avatar do usuário
Por Estevaoba 16 Dez 2019 às 18:59
Membro 5 Estrelas
Mensagens: 728
Reputação: 349
#51182
Tente esta em A2 da aba RESULTADO:
Código: Selecionar todos=SEERRO(ÍNDICE(Planilha1!$A$2:$F$9;CORRESP(Planilha2!$A2;Planilha1!$F$2:$F$9;0);CORRESP(A$1;Planilha1!$A$1:$F$1;0));"")

Copie para preencher a tabela.

Good luck!
Por ccbairros 07 Mai 2020 às 07:55
Membro Novato
Mensagens: 17
Reputação: 1
#54491
Desculpe a demora na resposta.
PQP vocês são F***, fechou certinho, só estou ajustando alguns parâmetros, mas ficou perfeito.
Muito obrigado mesmo.
Admin se quiser pode trancar o tópico, muito obrigado.