Utilize essa sessão para postar e solucionar desafios de Excel, matemáticos, lógicos, etc...
#61529
Bom-dia!

Numa pasta do servidor [ D:\Server\BemViver\Piscina\Armarios\DataOrigem ] é gravado de 15 em 15 minutos um ficheiro *.csv gerado automaticamente por um software de gestão.
O nome deste ficheiro *.csv é atribuido pela seguinte regra [ DataZ_XYZ_20210115_131500.csv ] onde:
O grupo [ DataZ_XYZ_ ] é fixo. Apenas mudam os grupos Data e Hora a que são gravados os ficheiros. A hora de gravação não é rigorosa, dependendo do delay de gravação.

Numa pasta [ D:\Server\BemViver\Piscina\Armarios ] tenho um ficheiro [ Status.Armarios.xlsx ] que está ligado SEMPRE AO ÚLTIMO ficheiro csv gravado.

Por exemplo
No Momento1 o ficheiro [ Status.Armarios.xlsx ] está ligado ao [ DataZ_XYZ_20210115_131500.csv ]
No Momento2 (15 minutos depois) o ficheiro [ Status.Armarios.xlsx ] deixa de estar ligado ao ficheiro [ DataZ_XYZ_20210115_131500.csv ] e passa a estar ligado ao ficheiro [ DataZ_XYZ_20210115_133025.csv ]
No Momento3 (15 minutos depois do Momento2) o ficheiro [ Status.Armarios.xlsx ] deixa de estar ligado ao ficheiro [ DataZ_XYZ_20210115_133025.csv ] e passa a estar ligado ao ficheiro [ DataZ_XYZ_20210115_134510.csv ]
(…)

O que pretendo é:
Atendendo a que, de 15 em 15 minutos é gravado e acrescentado um novo csv na pasta do servidor de acordo com a dita regra de gravação, como é que faço para que o ficheiro [ Status.Armarios.xlsx ] esteja sempre actualizado e ligado ao último ficheiro csv que foi inserido/gravado?

** No ficheiro csv, o nome da Folha/Sheet muda de acordo com o nome do ficheiro (nome da folha = nome do ficheiro).

Obrigado
Jesus Santos

Bom dia! No ficheiro "Indicadores de Cronogr[…]

EXPE.TEXTO-PEGAR O ZERO

Boa noite, babdallas!! Tudo bom? Perfeito, era i[…]

Porcentagem em das porcentagens

=MÉDIA(A1:A6)

Perdão, anexei o arquivo errado sem querer.[…]

Oi gente tudo bem eu estou fazendo uma planilha on[…]

Pessoal, boa tarde!! Tenho uma planilha de horas […]

Boa tarde!! Alguém sabe uma fórmula[…]

Boa tarde!! Alguém consegue me ajuda com u[…]