Tópicos relacionados a códigos VBA, gravação de macros, etc.
  • Avatar do usuário
Avatar do usuário
Por ADILSON21
#66130
Tenho uma planilha de extrato bancário (anexo). Só que as vezes a segunda, terceira ou a quarta linha faz parte da informação de um certo lançamento, porém eu gostaria que isso fosse transposto na frente do lançamento. Se abrirem o arquivo anexo ja irão entender o problema... Desde já grato.
Você não está autorizado a ver ou baixar esse anexo.
Por osvaldomp
#66133
#
Experimente. O código irá efetuar as alterações na própria tabela de dados.

Código: Selecionar todos
Sub RearranjaDados()
 Dim c As Range, LR As Long, b As Long, k As Long, x As Long, v As Long
  LR = Cells(Rows.Count, 3).End(3).Row
  b = Evaluate("MAX(FREQUENCY(IF(A5:A" & LR & "="""",ROW(A5:A" & LR & ")),IF(A5:A" & LR & "<>"""",ROW(A5:A" & LR & "))))")
  Application.ScreenUpdating = False
  Columns(4).Resize(, b).Insert
  For Each c In Range("B5:B" & LR).SpecialCells(4)
   If c.Offset(, 1).Value <> "SALDO DO DIA" Then
    k = c.Row
    If k > x + 1 Then
     c.Offset(, 1).Cut c.Offset(-1, 2)
     x = k: v = 0
    Else: v = v + 1: c.Offset(, 1).Cut c.Offset(-k - v + x, 1 + v + k - x): x = k
    End If
   End If
  Next c
End Sub

ADILSON21 agradeceu por isso

Em C5: =SEERRO(SE(PROCV(B3;'Registro Pendencia'!A[…]

Macro Relatório Diário

Bom dia pessoal! Preciso de ajuda para elaborar um[…]

Olá, @brunoangelo . Sugestão, d[…]

Calculo horas power query

Boa noite, pessoal Tenho um problema que ainda n&[…]

RESOLVIDO!!!

Apresentações: fale sobre você!

começando agora a aprender VBA estou gostan[…]

Veja se o anexo ajuda Obs.: foi todo ajustado no p[…]

Auxilio Calculo de Datas

Boa noite, Preciso da ajuda de vocês para q[…]