Tópicos relacionados a códigos VBA, gravação de macros, etc.
Por andriessen
#60747
Boa tarde!
o OSVALDOMB me deu esta formula
Range("J5").FormulaLocal = "=SE(E5=""diária"";A5*G5*I5+I5*(F5+H5)/2;A5*I5)"
Funciona perfeito para o que eu queria.
Pergunta:
Sei que a formula esta na coluna J mas nao sie que linha ela vai ser escrita pela macro (variavel)
Esta formula vai ser escrita na primeira vez que receber um cabeçalho e para as proximas linhas eu ja tenho uma macro que copia a linha de cima.
Como subtituir a linha 5 ( Existe algo tipo SE("6colunas a esquerda = ""diaria"",(8colunas a esq*3col esq.....
Deu pra entender?
Sempre sera a mesma linha , so preciso identificar as colunas.

Grato,.
Por osvaldomp
#60749
Seguem 3 chutes, apenas suposições, pois eu não entendi o que você quer.

Se não for isso então disponibilize o seu arquivo Excel contendo o que você quer.
Código: Selecionar todos
Sub TesteV1()
 Range("J2").FormulaLocal = "=SE(E2=""diária"";A2*G2*I2+I2*(F2+H2)/2;A2*I2)"
End Sub
Código: Selecionar todos
Sub TesteV2()
 Range("J2").Resize(9).FormulaLocal = "=SE(E2=""diária"";A2*G2*I2+I2*(F2+H2)/2;A2*I2)"
End Sub
Código: Selecionar todos
Sub TesteV3()
 Dim k As Long
  For k = 2 To 10
   Cells(k, "J").FormulaR1C1 = _
     "=IF(RC[-5]=""diária"",RC[-9]*RC[-3]*RC[-1]+RC[-1]*(RC[-4]+RC[-2])/2,RC[-9]*RC[-1])"
  Next k
End Sub


Bikke agradeceu por isso
Holerite filtrar

Bom dia Segue uma opção Até[…]

Contar Frequencia com Critérios

Acham que é muito dificil pessoal? :(

Caspirro, Bom Dia. Notei que voce esta colocando […]

Office 2019

Pessoal boa noite!! Alguém sabe me dizer […]

Olá Veja se era isso. Até Foxtri

Boa tarde amigos! Peço um auxílio, […]

[Resolvido] Filtro de Imagens

Camarada... perfeito... nem sei como lhe agradecer[…]

@osvaldomp Muitissimo Obrigado!!! Alé[…]