Pesquisa resultou em 1473 ocorrências

Voltar à pesquisa avançada

Experimente: 1. se a tabela já existe na planilha Sub FormataCélulas() Dim a As Range For Each a In Range("A1:A" & Cells(Rows.Count, 1).End(3).Row) a.Offset(, 1).Copy a.PasteSpecial Paste:=xlPasteFormats Next a End Sub 2. se a tabela será construída continuamente Private Sub Worksheet_...

Re: Instrução na abertura/fechamento tela cheia

por osvaldomp ¦ 19 Jan 2020 às 17:48 ¦ Fórum: Macros e VBA ¦ Tópico: Instrução na abertura/fechamento tela cheia ¦ Respostas: 3 ¦ Exibições: 19

Quanto à tecla Esc utlize os códigos abaixo e quanto à Barra de fórmulas verifique a configuração do seu Excel. Private Sub Workbook_Activate() Application.DisplayFullScreen = True Application.OnKey "{ESC}", "" End Sub Private Sub Workbook_Deactivate() Application.DisplayFullScre...

Re: Instrução na abertura/fechamento tela cheia

por osvaldomp ¦ 19 Jan 2020 às 14:21 ¦ Fórum: Macros e VBA ¦ Tópico: Instrução na abertura/fechamento tela cheia ¦ Respostas: 3 ¦ Exibições: 19

substitua:

Private Sub Workbook_Open() por Private Sub Workbook_Activate()

e

Private Sub Workbook_BeforeClose(Cancel As Boolean) por Private Sub Workbook_Deactivate()

Re: Condição SE e meses  [resolvido]

por osvaldomp ¦ 18 Jan 2020 às 17:56 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Condição SE e meses ¦ Respostas: 3 ¦ Exibições: 35

Código: Selecionar todos=PROC(MÊS(B2);{1;4;7;10};{"03T";"06T";"09T";"12T"})&" "&ANO(B2)

Experimente:

Código: Selecionar todos=EXT.TEXTO(A1;LOCALIZAR(".";A1)+1;4)

Re: Copiar formatação de uma planilha para outra

por osvaldomp ¦ 17 Jan 2020 às 19:28 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Copiar formatação de uma planilha para outra ¦ Respostas: 3 ¦ Exibições: 21

Segue uma solução via macro. Veja se aproveita. Sub PintaCélulas() Dim emp2 As Range, emp1 As Range For Each emp2 In Range("A2:A" & Cells(Rows.Count, 1).End(3).Row) Set emp1 = Sheets("Planilha1").[A:A].Find(emp2.Value) If Not emp1 Is Nothing Then emp2.Interior.ColorIndex = em...

Veja se ajuda.

Código: Selecionar todos=@F6&@G6&@H6

ou

Código: Selecionar todos=SE(@F6<>"";"OF";SE(@G6<>"";"OS";SE(@H6<>"";"OI";"")))

Re: Professor poderia me ajudar

por osvaldomp ¦ 17 Jan 2020 às 12:46 ¦ Fórum: Macros e VBA ¦ Tópico: Professor poderia me ajudar ¦ Respostas: 1 ¦ Exibições: 19

Tabela de dinamitos... Seria na planilha DINAMITOS, é isso? no final das fileiras ... Explique o que você quer dizer com "fileiras" pois esse termo não consta da documentação do Excel ... tem uma figura ... Que figura? Qual a sua localização? Seja específico. ... que preciso aplicar um ma...

Re: Função para contar repetição de texto ????

por osvaldomp ¦ 17 Jan 2020 às 09:58 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Função para contar repetição de texto ???? ¦ Respostas: 1 ¦ Exibições: 11

Código: Selecionar todos=CONT.SE(A:A;"*Dinheiro*")


Código: Selecionar todos=CONT.SE(A:A;"*Depósito*")


Código: Selecionar todos=CONT.SE(A:A;"*Dinheiro*Depósito*")

Bom dia, senhor icsi. 1. selecione A3:B17 / Copiar ~~~> cole em D3 e mantenha a seleção D3:E17 2. menu Dados / Remover Duplicatas / OK 3. em F3 coloque a função SOMARPRODUTO() que eu sugeri antes. Se essa for uma operação repetitiva então você poderá gravar uma macro e depois colocar o código aqui n...

Disponibilize uma nova planilha com exemplos. Coloque 3 ou 4 linhas preenchidas e TODAS as combinações desejadas.

Re: Formula da Condição em VBA

por osvaldomp ¦ 13 Jan 2020 às 16:57 ¦ Fórum: Macros e VBA ¦ Tópico: Formula da Condição em VBA ¦ Respostas: 3 ¦ Exibições: 15

Instale uma cópia do código abaixo no módulo da planilha. Private Sub Worksheet_Change(ByVal Target As Range) Dim Cx As Variant If Target.Address <> "$A$1" Then Exit Sub Cx = Array("VANDERNILSON", "LIDIANE", "EVELLYN", "ADRIANO") [B1] = Cx([A1] - 1) ...

Código: Selecionar todos=D3&" - "&E3&" - "&SOMARPRODUTO((A$2:A$13=D3)*(B$2:B$13=E3))

Re: Procv não funciona  [resolvido]

por osvaldomp ¦ 13 Jan 2020 às 13:40 ¦ Fórum: Macros e VBA ¦ Tópico: Procv não funciona ¦ Respostas: 3 ¦ Exibições: 24

O PROCV() funciona, porém o resultado não é o esperado porque na coluna C há valores que se parecem com números mas são textos.

Pra solucionar: selecione o intervalo com valores na coluna C / menu Dados / Texto para Colunas / Concluir

Experimente esta que funciona também em versões mais antigas do Excel.

Código: Selecionar todos=SOMARPRODUTO((A$2:A$13=D3)*(B$2:B$13=E3))

Experimente uma cópia da fórmula abaixo em F3 e arraste para baixo.

Código: Selecionar todos=CONT.SES(A$2:A$13;D3;B$2:B$13;E3)


obs. as grafias dos nomes devem ser iguais, assim, Júlia é diferente de Julia; ainda, nas células A7:A9 existe um espaço após o nome, que deve ser removido

Re: Contar uma palavra em várias células.  [resolvido]

por osvaldomp ¦ 11 Jan 2020 às 18:45 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Contar uma palavra em várias células. ¦ Respostas: 3 ¦ Exibições: 31

Olá, Geneci.

Veja se a fórmula abaixo atende.

Código: Selecionar todos="SULFABRIL "&CONT.SE(A2:A10;"*SULFABRIL")&" UNIDADES"

Re: Formatação de Valores Positivo ou Negativo  [resolvido]

por osvaldomp ¦ 09 Jan 2020 às 13:17 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Formatação de Valores Positivo ou Negativo ¦ Respostas: 3 ¦ Exibições: 24

Olá, Francisco. Talvez seja possível utilizar a Formatação que eu sugeri antes e incrementar a sua fórmula para que seja considerado o valor negativo. Nesse caso, se houver interesse, será necessário que você coloque a fórmula aqui no fórum. Segue uma opção via macro, sem utilizar a Formatação Condi...

Re: Fórmula para informações na diagonal  [resolvido]

por osvaldomp ¦ 08 Jan 2020 às 11:35 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Fórmula para informações na diagonal ¦ Respostas: 1 ¦ Exibições: 13

opção1
Selecione B1:B101 / Copiar / selecione qualquer célula vazia / Colar Especial ~~~> marque Transpor

opção2
Cole uma cópia da fórmula abaixo em qualquer célula vazia e arraste para a direita

Código: Selecionar todos=ÍNDICE($B1:$B101;COL(A1))

Re: Formatação de Valores Positivo ou Negativo  [resolvido]

por osvaldomp ¦ 07 Jan 2020 às 21:53 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Formatação de Valores Positivo ou Negativo ¦ Respostas: 3 ¦ Exibições: 24

Selecione E5: 1. menu Página Inicial / Formatação Condicional / Nova Regra / Usar uma Fórmula / na caixa de fórmula cole esta fórmula ~~~> =B$5="Débito" 2. Formatar / Personalizado / na caixa Tipo: cole este formato ~~~> -###.###,00 / OK 3x obs. se B5="Débito" , um valor positivo...