Pesquisa resultou em 1772 ocorrências

Voltar à pesquisa avançada

Re: Cria aba conforme lista

por osvaldomp ¦ 03 Ago 2020 às 17:04 ¦ Fórum: Macros e VBA ¦ Tópico: Cria aba conforme lista ¦ Respostas: 4 ¦ Exibições: 35

Me parece que o limite é de 31 caracteres. Se você quiser experimentar com 30, então altere no código conforme abaixo.

no lugar de ~~~> .Name = n.Value

coloque ~~~> .Name = Left(n.Value, 30)

Re: Contagem de dias entre intervalos de datas

por osvaldomp ¦ 02 Ago 2020 às 14:26 ¦ Fórum: Excel Básico ¦ Tópico: Contagem de dias entre intervalos de datas ¦ Respostas: 1 ¦ Exibições: 13

Olá, Sergio.

Veja se ajuda.

Código: Selecionar todos=SE(CONT.VALORES(A2:F2)<6;"";B2-A2+D2-C2+F2-E2)

Re: RECORDAR COMO FAZER UMA COMPARAÇÃO  [resolvido]

por osvaldomp ¦ 01 Ago 2020 às 13:56 ¦ Fórum: Macros e VBA ¦ Tópico: RECORDAR COMO FAZER UMA COMPARAÇÃO ¦ Respostas: 2 ¦ Exibições: 18

estyfodense escreveu:*Caso ... tivesse o nome "Futebol" na celular


Na célula o comando abaixo funciona, já na celular ... :?:

Código: Selecionar todosIf Sheets("Planilha1").Cells(linha, 1) Like "*Futebol" Then

Re: Caracteres "NF-"  [resolvido]

por osvaldomp ¦ 31 Jul 2020 às 18:02 ¦ Fórum: Macros e VBA ¦ Tópico: Caracteres "NF-" ¦ Respostas: 2 ¦ Exibições: 27

Experimente uma cópia do código abaixo no módulo da planilha Controle NF-e . Private Sub Worksheet_Change(ByVal Target As Range) If Target.Count > 1 Then Exit Sub If Target.Column <> 2 Or Left(Target.Value, 1) = "N" Then Exit Sub Target.Value = "NF-" & Target.Value End Sub Al...

Re: Cria aba conforme lista

por osvaldomp ¦ 31 Jul 2020 às 17:47 ¦ Fórum: Macros e VBA ¦ Tópico: Cria aba conforme lista ¦ Respostas: 4 ¦ Exibições: 35

Experimente: Sub InserePlanilhas() Dim n As Range Application.ScreenUpdating = False With Sheets("DADOS") For Each n In .Range("B2:B" & .Cells(Rows.Count, 2).End(3).Row) Sheets.Add after:=Sheets(Sheets.Count) With ActiveSheet .[C5:I5] = Array("NOME", , , , "DAT...

Re: MACRO BLOQUEADA, COMO DESBLOQUEAR?

por osvaldomp ¦ 31 Jul 2020 às 16:30 ¦ Fórum: Macros e VBA ¦ Tópico: MACRO BLOQUEADA, COMO DESBLOQUEAR? ¦ Respostas: 1 ¦ Exibições: 14

Se o projeto está protegido, então desprotegê-lo sem a autorização do proprietário é procedimento ilícito.

Eu sugiro que você procure autorização com o proprietário.

Re: Condição SE  [resolvido]

por osvaldomp ¦ 30 Jul 2020 às 16:33 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Condição SE ¦ Respostas: 2 ¦ Exibições: 18

=PROC(A1;{0;2;6;11;51;101;501;1001};{"aceitável";"muito baixo";"baixo";"significante";"alto";"muito alto";"extremo";"inaceitável"}) =SE(A1<2;"aceitável";SE(A1<6;"muito baixo";SE(A1<11;"baixo&quo...

Re: Colar Valores  [resolvido]

por osvaldomp ¦ 29 Jul 2020 às 13:39 ¦ Fórum: Macros e VBA ¦ Tópico: Colar Valores ¦ Respostas: 5 ¦ Exibições: 24

Experimente:

Código: Selecionar todosRelatorio.Range("A" & LinRelatorio & ":E" & LinRelatorio) = wshSelecionada.Range("D" & i.Row & ":H" & i.Row).Value

Re: Erro no SOMASES

por osvaldomp ¦ 28 Jul 2020 às 15:15 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Erro no SOMASES ¦ Respostas: 4 ¦ Exibições: 120

Experimente:

Código: Selecionar todos=SOMARPRODUTO(N(A2:A7=A9)*N(E2:E7=A8)*N(B2:B7=C2:C7);(D2:D7))

Re: Macro para auto preencher datas em diversas planilhas  [resolvido]

por osvaldomp ¦ 28 Jul 2020 às 12:04 ¦ Fórum: Macros e VBA ¦ Tópico: Macro para auto preencher datas em diversas planilhas ¦ Respostas: 4 ¦ Exibições: 106

Passei batido pelas datas. Corrigido abaixo. Desculpe. Acrescentei as bordas. Sub InsereDatasV2() Dim ws As Worksheet, k As Long For Each ws In ThisWorkbook.Sheets k = DateDiff("m", ws.[E2], ws.[F2]) ws.[A4] = ws.[E2] ws.[A5] = DateSerial(Year(ws.[E2]), Month(ws.[E2]) + 1, 1) ws.[A6].Resiz...

Re: Macro para auto preencher datas em diversas planilhas  [resolvido]

por osvaldomp ¦ 28 Jul 2020 às 05:29 ¦ Fórum: Macros e VBA ¦ Tópico: Macro para auto preencher datas em diversas planilhas ¦ Respostas: 4 ¦ Exibições: 106

Experimente:

Código: Selecionar todosSub InsereDatas()
 Dim ws As Worksheet
  For Each ws In ThisWorkbook.Sheets
   ws.[A4] = ws.[E2]: ws.[A4].AutoFill ws.[A4].Resize(ws.[F2] - ws.[E2] + 1)
  Next ws
End Sub

Re: Formatação condicional baseada em 2 condições?

por osvaldomp ¦ 27 Jul 2020 às 16:10 ¦ Fórum: Excel Básico ¦ Tópico: Formatação condicional baseada em 2 condições? ¦ Respostas: 3 ¦ Exibições: 115

Experimente:

Código: Selecionar todos=E($A1<>"";$A1<HOJE()+2;$D1="")

Re: Arrastar fórmulas personalizado  [resolvido]

por osvaldomp ¦ 26 Jul 2020 às 09:57 ¦ Fórum: Excel Básico ¦ Tópico: Arrastar fórmulas personalizado ¦ Respostas: 4 ¦ Exibições: 72

Experimente a fórmula abaixo na linha 1 de qualquer coluna da Planilha2 e arraste para baixo.

Código: Selecionar todos=SE(ÉERRO(ESCOLHER(INT(MOD(LIN();6));1;7;1));"";INDIRETO("'Planilha1'!"&DESLOC(A$1;INT((LINS(A$1:A1)-1)/6);MOD(LIN()-1;3))))

Re: Preenchimento automático de horário final

por osvaldomp ¦ 25 Jul 2020 às 08:33 ¦ Fórum: Macros e VBA ¦ Tópico: Preenchimento automático de horário final ¦ Respostas: 1 ¦ Exibições: 40

Um exemplo, para inserir a hora atual em H10:

Código: Selecionar todosRange("H10") = Time

Experimente:

Código: Selecionar todos=PROC(2; 1/(B1:B20>0); B1:B20)

Experimente a fórmula matricial abaixo.

Código: Selecionar todos=ÍNDICE(H$4:H$12;CORRESP(MÍNIMO(ABS(H$4:H$12-D4));ABS(H$4:H$12-D4);0))


obs. por tratar-se de fórmula matricial, após colar a fórmula em uma célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter, depois arraste para baixo.

Re: Alterar o tamanho de uma imagem no e-mail (excel - VBA)

por osvaldomp ¦ 24 Jul 2020 às 13:07 ¦ Fórum: Macros e VBA ¦ Tópico: Alterar o tamanho de uma imagem no e-mail (excel - VBA) ¦ Respostas: 2 ¦ Exibições: 51

Experimente: Sub EmailIntervaloDePlanilha() Application.ScreenUpdating = False Range("G1:AL24").CopyPicture xlScreen, xlPicture Sheets.Add ActiveSheet.Paste Destination:=Range("A1") With Selection .ShapeRange.LockAspectRatio = msoTrue .ShapeRange.Width = .ShapeRange.Width * 0.45 ...

Re: Como fixar uma aba anterior em uma referência?

por osvaldomp ¦ 24 Jul 2020 às 08:48 ¦ Fórum: Fórmulas e Funções ¦ Tópico: Como fixar uma aba anterior em uma referência? ¦ Respostas: 5 ¦ Exibições: 110

É possível via UDF.

Retorne se houver interesse.

Em D1

=SE(C1="";"";"coloque aqui a tal informação pertinente a C1 ;) ")

Re: impedir nomes repetidos - células com validação  [resolvido]

por osvaldomp ¦ 18 Jul 2020 às 15:18 ¦ Fórum: Macros e VBA ¦ Tópico: impedir nomes repetidos - células com validação ¦ Respostas: 6 ¦ Exibições: 90

Olá, Albino. Agora entendi. Coloque uma cópia do código abaixo no lugar do anterior. Já ajustei o código considerando as colunas que você adicionou na tabela. Private Sub Worksheet_Change(ByVal Target As Range) Dim k As Boolean If Target.Count > 1 Then Exit Sub If Intersect(Target, Columns("C:L...